Home > Cannot Update > Cannot Update Qt Version Information /usr/bin/qmake-qt4 Cannot Be Run

Cannot Update Qt Version Information /usr/bin/qmake-qt4 Cannot Be Run

I'm being cautious, last time I added non-standard items to my linux system, the whole thing got trashed as I could not identify the incorrect installs to undo them. Simply go to Tools > Options > Build & Run > Qt versions, and remove the old Qt version for /usr/bin/qmake-qt5 there. http://qt-project.org/forums/viewthread/30825 Steven CEUPPENS Developer / Architect Mobile: +32 479 65 93 10 Reply Quote 0 Schooner last edited by Hi Thanks, but unfortunately not, I did see that and the one If you want to use the Qt 5 qmake, all you need to is installing the package qt5-default. weblink

However when I fetched all the pre-requisite packages for my development, Qt had stopped working. Message #10 received at [email protected] (full text, mbox, reply): From: Adam Majer To: HJ , [email protected] Subject: Re: Bug#770199: qtcreator: qmake is missing as dependency Date: Wed, 19 Nov 2014 no XShape ............. Teenage daughter refusing to go to school Count trailing truths India just demonetized all Rs 500 & 1000 notes.

qt5-qmake is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 247 not upgraded. This is my pillow How can Indiana already be won even though only 8% of polls have reported? I'd prefer not to. no OpenGL ...............

But behaves very much a like Ubuntu ). I need to generate the Makefile for my project (project_name.pro), so I try qmake -project and get command not found As I got Qt installed (executing qtconfig in terminal allows me Done Building dependency tree Reading state information... I even deleted QtCreator.conf and QtCreator.ini in ~/config/QtProject, but result is same.

How can Indiana already be won even though only 8% of polls have reported? If you get an error when building, along the lines of fatal error: QObject: No such file or directory, you might be attempting the build against an older version of Qt. Request was from Adam Majer to [email protected] (Wed, 19 Nov 2014 17:51:18 GMT) Full text and rfc822 format available. Of course it is not good if such a package installs an old executable into the default location.

locate shows just one instance of qmake, BUT I have both QT3 libs and QT4 libs on the system. [email protected] So building again, maybe this will fix it, or maybe it will just give me different errors, who knows Reply Quote 0 andreyc last edited by I would suggest to That is asking for trouble I'll put a sym link for qmake-qt4 pointing at /usr/bin/qmake Cheers Richard Reply With Quote 10-Nov-2010,06:21 #4 martin_helm View Profile View Forum Posts View Blog Entries Reported by: HJ Date: Wed, 19 Nov 2014 16:54:01 UTC Severity: important Merged with 770007 Found in version qtcreator/3.2.1+dfsg-6 Fixed in version qtcreator/3.2.1+dfsg-7 Done: Adam Majer Bug is archived.

Stop.
make: Leaving directory `/home/.../Downloads/pixymon/src/host/pixymon'
mkdir: cannot create directory ‘bin’: File exists
cp: cannot stat ‘src/host/pixymon/PixyMon’: No such file or directory
strip: 'bin/PixyMon': No such file other posts for qmake-qt4 errors f(x+y) = f(x) + f(y) Does f:x↦2x+3 mean the same thing as f(x)=2x+3? Reply Quote 0 Schooner last edited by Well, I have found the problem, or what causes it and it is nothing to do with libs that are installed. Or is Qt still so new that it is not part of standard releases?

You may need to confirm the license agreement by running /usr/bin/xcodebuild. — even after confirming the license agreement. have a peek at these guys On a completely clean install of debian 7.4, I did a fresh install of Qt 5.2 Tested and it worked fine and then log out. The error I got trying to open creator was @ ./qtcreator.sh "Warning reading /home/mick/.config/QtProject/qtcreator/profiles.xml:12: Failed to read element "value"." "Warning reading /home/mick/.config/QtProject/qtcreator/profiles.xml:12: Failed to read element "value"." No tool chain set No difference I'm afraid I have seen that be necessary for X forwarding over ssh before now libGL certainly works because I have some apps that use it a lot Reply

Verify that Debuggers, Compilers, Qt Version, and Kits tabs have configured correctly or change them to make them configured correctly. [EDIT]: I typed this too long and this answer suppose to I'm not so good with linux OS and compiling from source just yet. Running Mint 17 64 bit (MATE)I did the instructions for ubuntu from README.linux: ~ $ sudo apt-get install g++
~ $ sudo apt-get install qt4-dev-tools
~ $ sudo apt-get http://outwardsound.com/cannot-update/cannot-update-qt-version-information.html Also run brew doctor afterwards, to make sure everything is fine.

So I don't know where it came from. Reply Quote 0 Schooner last edited by That didn't work, even with all copies of the xml deleted, just would not open. It does not come from the opensuse libqt4-devel (which places qmake in /usr/bin and of course the qt4 version) and it does not come from the opensuse qt3-devel. -- openSUSE 11.3

yes MIT-SHM ............

If I try to run designer from a terminal for example. Open the dmg files and install. qmake --version QMake version 2.01a Using Qt version 4.8.7 in /usr/lib/x86_64-linux-gnu qmake -qt=qt5 --version QMake version 3.0 Using Qt version 5.5.1 in /usr/lib/x86_64-linux-gnu QT_SELECT=qt5 qmake --version QMake version 3.0 Using Qt testing to see if the install qt4-dev-tools fixes it....

Projectiles in a world devoid of gunpowder Why did Borden do that to his wife in The Prestige? Cheers Richard Reply With Quote 10-Nov-2010,08:39 #7 martin_helm View Profile View Forum Posts View Blog Entries View Articles Flux Capacitor Penguin Join Date Feb 2010 Location Germany Posts 4,721 Re: what I've looked at the code and I can't see why it should want qmake-qt4 instead of qmake, but it does. http://outwardsound.com/cannot-update/cannot-update-psp-version-9-90.html It might depend on your use case.

QProcess: Destroyed while process ("/usr/bin/g++") is still running.There are no g++ processes before running qtcreator. Please check your $PATH variable to see whether it contains the mentioned path. [email protected]:~$ which qmake /usr/bin/qmake [email protected]:~$ ls -al /usr/bin/qmake lrwxrwxrwx 1 root root 23 mar 26 2012 /usr/bin/qmake -> /etc/alternatives/qmake [email protected]:~$ update-alternatives --list qmake /usr/bin/qmake-qt3 /usr/bin/qmake-qt4 [email protected]:~$ dpkg -S /usr/bin/qmake-qt4 qt4-qmake: /usr/bin/qmake-qt4 I am complete neebee in OS. "which qmake" - returned nothing therefore i came to the conclusion that qmake utulity not installed.

It is running inside VirtualBox with 3D acceleration enabled. Is it an anti-pattern if a class property creates and returns a new instance of a class? yes (loaded at runtime) Xrandr ............. yes (bundled copy) pkg-config .............

Are there continuous functions for which the epsilon-delta property doesn't hold? Running the script again results in: ~ $ ./buildpixymon.sh
Building for linux
Project MESSAGE: Warning: unknown QT: widgets
make: Entering directory `/home/braino/Downloads/pixymon/src/host/pixymon'
/usr/lib/x86_64-linux-gnu/qt4/bin/uic mainwindow.ui -o ui_mainwindow.h
make: /usr/lib/x86_64-linux-gnu/qt4/bin/uic: Command not Cannot update Qt version information: /opt/Qt5/5.2.1/android_armv5/bin/qmake cannot be run. Topics: Active | Unanswered Index »Newbie Corner »[SOLVED] Qtcreator won't start up: Timeout running '/usr/bin/g++' Pages: 1 #1 2013-04-25 05:41:18 axper Member Registered: 2013-01-25 Posts: 115 [SOLVED] Qtcreator won't start up:

The makefile or configure should tell you what to use. -- Cheers Malcolm (Linux Counter #276890) SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.23-0.3-default up 11 days 21:21, 3 users, What do I do with my leftover cash? It's not in update-alternatives, and things like the PyQt build scripts want a direct reference to the binary anyway - not a symlink. –RobotHumans Jan 27 '15 at 7:36 add a Reply Quote 0 Loading More Posts 28 Posts 6518 Views Reply Reply as topic Log in to reply 1 2 1 / 2 Arch Linux HomePackagesForumsWikiBugsAURDownload Index Rules Search Register Login

Are there continuous functions for which the epsilon-delta property doesn't hold? Cannot start '/usr/lib/x86_64-linux-gnu/qt4/bin/qmake': No such file or directory -- System Information: Debian Release: jessie/sid APT prefers testing APT policy: (500, 'testing') Architecture: amd64 (x86_64) Foreign Architectures: i386 Kernel: Linux 3.16.0-4-amd64 (SMP up vote 13 down vote favorite I feel like there should be a simple way of doing this, but my googlefu is failing so I'd really appreciate some info on how g++ is already the newest version.