Home > Configure Error > Configure Error Cannot Find Glib-2.0 Or Later

Configure Error Cannot Find Glib-2.0 Or Later

If GLIB is installed *** but not in the same location as pkg-config add the location of the file *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH. [root( at )localhost atk-1.6.0]# Same You will need to install it if you don't have it. On 1941 Dec 7, could Japan have destroyed the Panama Canal instead of Pearl Harbor in a surprise attack? then modified the paths. –awhitesong Mar 14 '15 at 15:35 Thanks for the concern. Check This Out

Also, if you are installing in a system directory, on some systems (such as Linux), you will need to run ldconfig after make install so that the newly installed libraries will RaVilj View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by RaVilj 06-18-2004, 06:55 AM #2 mhearn LQ Guru Registered: Nov 2002 Location: comp12345 View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by comp12345 06-18-2004, 04:20 PM #6 RaVilj LQ Newbie Registered: Jun 2003 Location: Oh I am running Redhat 9.0, Kernel: Linux 2.4.20-8smp.

RaVilj View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by RaVilj 06-18-2004, 02:20 PM #4 RaVilj LQ Newbie Registered: Jun 2003 Location: Antonym for Nourish How much time would it take for a planet scale Miller-Urey experiment to generate intelligent life more hot questions question feed about us tour help blog chat data Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home Forums HCL Reviews Tutorials Articles Register Search Search Forums Advanced Search Search Tags Search LQ Wiki Search Tutorials/Articles Search See the pkg-config man page for more details.

Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign up using Facebook Sign up using Email and Password Post as a guest Name Having a problem logging in? How do pilots identify the taxi path to the runway? Finally the PKG_CONFIG_PATH environment variable contains a search path that pkg-config (see below) uses when looking for for file describing how to compile programs using different libraries.

Doing this fixed my issues as mentioned above. The latest version of *** GLIB is always available from ftp://ftp.gtk.org/. no look at this : Code: checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for ANSI C header files... Package glib -2.0 was not found in the pkg-config search path.

another problem... Have you tried an apt-get install --reinstall of the relevant packages? –steeldriver Mar 14 '15 at 15:30 It was installed from source. Was going to answer it myself after a while. configure: error: *** Glib 2.4.0 or better is required.

Now GTK+-1.2.10 installs perfectly after installing Glib-1.2.10. Post your question in this forum. Recent glib versions doesn't have all the compilation schemas in /usr/share/glib-2.0/schemas. Please set GLIB_CFLAGS and GLIB_LIBS to the correct values or pass --with-internal-glib to configure to use the bundled copy.

I know that GTK+-2.4.0 requires ATK and pango to install but these both have the same problem when trying to configure them... his comment is here Adv Reply March 17th, 2008 #5 lnostdal View Profile View Forum Posts Banned Join Date Jan 2006 Beans 961 Re: Cannot find glib every development library(#1) starts with the string RaVilj View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by RaVilj Thread Tools Show Printable Version Email this Page Search this Thread Advanced How safe is 48V DC?

  1. I have the following: - glib-2.4.0 - gtk+-2.4.0 - pango-1.4.0 - atk-1.6.0 Now I successfully installed glib-2.4.0 without any errors or warnings of (./con figure -> make -> make install).
  2. If pkg-config was correct, then it is best *** to remove the old version of GLib.
  3. Alternatively, you may set the environment variables PACKAGE_CFLAGS and PACKAGE_LIBS to avoid the need to call pkg-config.
  4. yes checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.9.0...
  5. Introduction to Linux - A Hands on Guide This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started
  6. Ask Ubuntu works best with JavaScript enabled current community chat Stack Overflow Meta Stack Overflow your communities Sign up or log in to customize your list.
  7. LinuxQuestions.org > Forums > Linux Forums > Linux - Software Glib & GTK+ versions 1.2.10 & 2.4.0 User Name Remember Me?
  8. Visit the following links: Site Howto | Site FAQ | Sitemap | Register Now If you have any problems with the registration process or your account login, please contact us.
  9. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed
  10. share|improve this answer answered Apr 22 '14 at 11:19 Shinobii 4333926 5 Running these commands on Ubuntu 12.04 gives the error: configure: error: Either a previously installed pkg-config or "glib-2.0

Empty lines or not? Its urgent. Here is the error from Pango, ATK and GTK+ configures: Code: GLIB 2.0.0 or better is required. this contact form dani Last edited by dgcampos; March 12th, 2008 at 01:52 AM.

Make sure it is in your PATH or set the PKG_CONFIG environment variable to the full path to pkg-config. As I said above is that I have installed it, restarted and all... Adv Reply March 12th, 2008 #2 lnostdal View Profile View Forum Posts Banned Join Date Jan 2006 Beans 961 Re: Cannot find glib you already have glib installed actually ..

but, since you are compiling something it is most likely looking for the development-files for glib Code: [email protected]:~# sudo aptitude search glib | grep dev p bglibs-dev - BG Libraries Collection

Why did Michael Corleone not forgive his brother Fredo? no configure: error: *** GLIB 2.0.0 or better is required. Contact Us - Advertising Info - Rules - LQ Merchandise - Donations - Contributing Member - LQ Sitemap - Main Menu Linux Forum Android Forum Chrome OS Forum Search LQ Just this specific problem or the whole downgrading process, which i believe although worked still shouldn't be followed as a recommended procedure since i manually deleted some files?

Why is (a % 256) different than (a & 0xFF)? You can get it from: ftp://ftp.gtk.org/pub/gtk [email protected]:~/ProyectosGlade/proyecto1$ sudo apt-get install glib Leyendo lista de paquetes... The problem is after typing this into the terminal followed by the ./configure command, I still receive this error. navigate here thank you very much to everyone.

How to decline a postdoc interview if there is some possible future collaboration? Code: sudo aptitude install libgtk2.0-dev #1: at least the C based ones Last edited by lnostdal; March 17th, 2008 at 09:07 AM. What exactly is the alpha in the `Dirichlet Distribution`? How can Indiana already be won even though only 8% of polls have reported?

Registration is quick, simple and absolutely free. How to grep two numbers from the same line at different places using bash? Join them; it only takes a minute: Sign up Cannot find pkg-config error up vote 8 down vote favorite 3 I am trying to install some software on my mac; however I know that GTK+-2.4.0 requires ATK and pango to install but these both have the same problem when trying to configure them...

Notices Welcome to LinuxQuestions.org, a friendly and active Linux Community. Join our community today! Alternating Fibonacci Would we find alien music meaningful? Why place camera inside box, during court?

Last edited by RaVilj; 06-18-2004 at 08:31 AM. If you'd like to contribute content, let us know. Now glib-1.2.10 installed its *.pc files to /usr/lib/pkgconfig where glib-2.4.0 installed its *.pc files to /usr/local/lib/pkgconfig. When trying to install GTK+-2.4.0 it claims that it cannot find Glib-2.4.0 and suggests some thing about pkg_config_path environment variable.

I just started my first real job, and have been asked to organize the office party. Thanks! –Mandx Jul 13 '15 at 17:35 @Mandx Actually my main aim was to downgrade glib-2.42 to 2.28 and get it working properly in the system. Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. i worked out, but now...

Please visit this page to clear all LQ-related cookies. Build me a brick wall! The latest version of *** GLIB is always available from ftp://ftp.gtk.org/.