Home > Configure Error > Configure Error Cannot Find Glib Version = 2.10.1

Configure Error Cannot Find Glib Version = 2.10.1

Suggested Solutions Title # Comments Views Activity Mac telnet client seems to skip part of login script? 12 43 55d Android Security Model 3 46 39d Which maximum version of Zabbix configure: error: Package requirements (gtk+-2.0 >= 2.0.0) were not met: No package 'gtk+-2.0' found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. pkg-config retrieves information about packages from special metadata files. i worked out, but now... Check This Out

This tutorial will show you how to backup your system files and keep regular intervals. Unfortunately it's not as easy as just pointing to the location, where it is stored, but leave that for the long answer at the end and take a look at the Why is looping over find's output bad practice? no *** Could not run GLIB test program, checking why... *** The test program failed to compile or link.

This usually means GLIB is incorrectly installed.
configure: error: Cannot find GLIB version >= 2.10.1: is pkg-config in path?

とのエラーになりました。glibは入っているようですがよくわかりません。古い?
# pkg-config --modversion glib-2.0
2.4.1

過去のスレッドを拝見し、eventlogのインストールが必要ということがわかりましたので、それは終了しています。
上記のエラーを回避するにはどのようにすればよいでしょうか

unix初心者の為よくわかりません。よろしくお願いします。 Alternatively, you may set the environment variables EVTLOG_CFLAGS and EVTLOG_LIBS to avoid the need to call pkg-config. solution: yum install glib2-devel Comments (2) Hadi sarabi/ Reply October 11, 2015 Thank you very much,this very helpful for my work. Your first 5 minutes are always free.

  1. Please let me know your thoughts. 0 LVL 16 Overall: Level 16 Linux 14 Linux Distributions 8 Message Accepted Solution by:ai_ja_nai2009-02-12 ai_ja_nai earned 125 total points Comment Utility Permalink(# a23624451)
  2. But I don't really understand, why for example export PKG_CONFIG_PATH=/home//install/glib/lib/ doesn't work.
  3. Adv Reply Quick Navigation Programming Talk Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums The Ubuntu Forum Community Ubuntu Official Flavours Support New to
  4. Join Now For immediate help use Live now!
  5. Join and Comment By clicking you are agreeing to Experts Exchange's Terms of Use.
  6. Adv Reply March 17th, 2008 #5 lnostdal View Profile View Forum Posts Banned Join Date Jan 2006 Beans 961 Re: Cannot find glib every development library(#1) starts with the string
  7. Nevertheless you can find out the compiled in standard directories by running pkg-config --variable pc_path pkg-config which for example prints /usr/local/lib/pkgconfig:/usr/local/lib/pkgconfig/i486-linux-gnu:/usr/local/share/pkgconfig:/usr/lib/pkgconfig:/usr/lib/pkgconfig/i486-linux-gnu:/usr/share/pkgconfig on my system.
  8. Privacy Policy Site Map Support Terms of Use
  9. If GLIB is installed *** but not in the same location as pkg-config add the location of the file *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

another problem... Package eventlog was not found in the pkg-config search path.
Perhaps you should add the directory containing `eventlog.pc'
to the PKG_CONFIG_PATH environment variable
No package 'eventlog' found
no
configure: error: Cannot i.e. @[email protected] was filled with the argument given as --prefix= on the command line, while others like @[email protected] were filled with parameters detected by the configure script. Join & Ask a Question Need Help in Real-Time?

The package name specified on the pkg-config command line is defined to be the name of the metadata file, minus the .pc extension. yes checking for PACKAGE... Projectiles in a world devoid of gunpowder What would be the consequences of a world that has only one dominant species of non-oceanic animal life? no

とのエラーになりました。glibは入っているようですがよくわかりません。古い?
# pkg-config --modversion glib-2.0
2.4.1




この表記で必要バージョン未満というのはわかると思いますので、
http://www.gtk.org/download.html
から落として入れてあげればいいんではないでしょうか?

#環境書いていないのでわかりませんが、必ずしも

Twitter Facebook Digg Vimeo YouTube Skype

FAQ Forum Quick Links Unanswered Posts New Posts View Forum Leaders FAQ Contact an Admin Forum Community Forum Council FC Agenda Forum Governance Forum i try this command : [email protected]:~/ProyectosGlade/proyecto1$ ./autogen.sh **Error**: You must have `glib' installed. If a library can install multiple versions simultaneously, it must give each version its own name (for example, GTK 1.2 might have the package name "gtk+" while GTK 2.0 has "gtk+-2.0"). On most systems, pkg-config looks in and for these files.

asked 3 years ago viewed 1502 times active 3 years ago Upcoming Events 2016 Community Moderator Election ends Nov 22 Visit Chat Related 1where to point compile flags?1fail to compiled glib1Cross The primary question: Has anyone else used syslog-ng 3 on a server and would like to direct me to instructions? I tried installed both a .deb archive, and compiling the source myself, but failed. ac_cv_env_PKG_CONFIG_PATH_value=/foobar/glib-2.35.8/: GLIB_CFLAGS='' GLIB_COMPILE_RESOURCES='' GLIB_GENMARSHAL='' GLIB_LIBS='' GLIB_MKENUMS='' GLIB_PACKAGES='gobject-2.0' GLIB_REQUIRED_VERSION='2.31.2' PKG_CONFIG_PATH='/foobar/glib-2.35.8/:' Any idea what's wrong here and how to fix it?

yes checking for GLIB - version >= 2.10.1... http://outwardsound.com/configure-error/configure-error-cannot-find-glib-2-0-or-later.html Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.: Linux Unix OS Linux/ Thelinuxfaq/ Reply October 12, 2015 Thank you so much... :) Leave a Comment Name: Reply to: Email: * Message: * Posting your comment... no look at this : Code: checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for ANSI C header files...

Posted on 2009-02-11 Linux Distributions Linux 8 1 solution 1,600 Views Last Modified: 2013-12-06 I'm trying to install syslog-ng and I've run into a problem when compiling the source. The reason trying to just point PKG_CONFIG_PATH to the build directory of your glib won't work as the path specified in the .pc ist the installation directory and not the location echo return $RETVAL } restart() { stop start } Now, Determine your application utilizing the below commands, # /etc/init.d/syslog-ng start Starting syslog-ng: [ OK ] # /etc/init.d/syslog-ng this contact form Hecho Creando 疵bol de dependencias Leyendo informacin de estado...

What's the most robust way to list installed software in debian based distros? Browse other questions tagged linux compilation configure glib or ask your own question. If GLIB is installed *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

Code: sudo aptitude install libgtk2.0-dev #1: at least the C based ones Last edited by lnostdal; March 17th, 2008 at 09:07 AM.

All rights reserved. Covered by US Patent. First Name Please enter a first name Last Name Please enter a last name Email We will never share this with anyone. Subscribe to our monthly newsletter for tech news and trends Membership How it Works Gigs Live Careers Plans and Pricing For Business Become an Expert Resource Center About Us Who We

but, since you are compiling something it is most likely looking for the development-files for glib Code: [email protected]:~# sudo aptitude search glib | grep dev p bglibs-dev - BG Libraries Collection That's all I can think right now 0 Message Author Comment by:Abarros222009-02-17 Comment Utility Permalink(# a23662439) Hello, I decided to install a previous version of syslog-ng and it worked. Dishwasher Hose Clamps won't open What exactly is the alpha in the `Dirichlet Distribution`? navigate here AFAICT syslog-ng 3 isn't in Ubuntus repos?

This question was not about syslog-ng troubles, was about removing glibc. Suppose this glib is in /foobar/glib-2.35.8. I don't know, in the sense that if the new version breaks the retrocompatibility ALL those programs will stop working. Make a file and add below line, # vim /etc/sysconfig/syslog-ng SYSLOGNG_PID="/var/run/syslog-ng.pid" SYSLOGNG_OPTIONS="-p $SYSLOGNG_PID" SYSLOGNG_COMPAT_PID="/var/run/syslogd.pid" Same as, make a syslog-ng file under /etc/init.d/ directory and give Execute permission. # touch

Well you can use Timeshift in Linux to perform those similar action. no configure: error: Package requirements (glib-2.0 >= 2.10.1 gmodule-2.0 gthread-2.0) were not met: No package 'glib-2.0' found No package 'gmodule-2.0' found No package 'gthread-2.0' found Consider adjusting the PKG_CONFIG_PATH environment variable So I just downloaded glib 2.35.8 and did successfully ./configure and make for it (I don't want to install it system-wide so I didn't do make install). Why is the dialogue 'You talking to me' from the movie 'Taxi Driver' so famous?

At least if the library itself doesn't contain any hardwired pathes, but that would only be a problem at runtime not while linking. Now I cd to /foobar/atk-2.7.91 and export the PKG_CONFIG_PATH: export PKG_CONFIG_PATH=/foobar/glib-2.35.8:$PKG_CONFIG_PATH. How do I uninstall the previous version of GLIB? 0 Comment Question by:Abarros22 Facebook Twitter LinkedIn Email https://www.experts-exchange.com/questions/24135574/How-do-you-uninstall-a-previous-version-of-GLIB.htmlcopy LVL 16 Best Solution byai_ja_nai Usually, makefiles provide good hints on possible causes Do you want to help us debug the posting issues ? < is the place to report it, thanks !

Note窶ヲ Linux Distributions Linux/ Unix Bash Shell: Finding Files Video by: Dototot Learn how to find files with the shell using the find and locate commands. Teenage daughter refusing to go to school When does 窶徂aben窶 push 窶從icht窶 to the end of the sentence? All rights reserved. Ubuntu Logo, Ubuntu and Canonical ゥ Canonical Ltd.