Home > Freebsd Cannot > Freebsd Cannot Read Termcap Database Using Dumb Terminal Settings

Freebsd Cannot Read Termcap Database Using Dumb Terminal Settings

Can you suggest that the appropriate package to install > on Ubuntu? Once I upgraded my home router (which will be a story for a future article), I found that the procedure wasn't that complicated, even easy, and that I would have better I have made patches using the changes against bin/sh in NetBSD. I solved it > by using this command: LD_PRELOAD = /lib/libreadline.so.5 ./psql then your data> I am still getting this problem. navigate here

Please don't fill out this field. Aborted" On Thu, Jan 6, 2011 at 8:54 PM, Gabe Nell <[hidden email]> wrote: >> There was a change in 9.0.2 to use libedit instead of readline for >> this (readline One of my colleagues has tested >> the issue reported and confirmed that installing the OS's termcap >> package should solve the problem. > > Ubuntu doesn't seem to use termcap, postgres(at)debian:~$ /opt/PostgreSQL/9.0/bin/psql Password: psql (9.0.2) Type "help" for help.

I have the same problem today was to install and create db in > PSQL program in PostgreSQL 9.0.2 (Ubuntu 10.10 (32bit)). Once you authenticate the following error message will be displayed: Cannot read termcap database; using dumb terminal settings. * Received error that the termcap database could not be read. * N/A Once again, make backups, test on a virtual machine and/or a test server first.

I do the fresh install of 9.0.2 from the binary installer. o usb/146799 usb usbdevs(8) missing in ObsoleteFiles.inc o ports/146798 miwi New Port: multimedia/libvpx VP8 Codec SDK o ports/146795 wen update port: science/massxpert fixed mans o ports/146794 ale lang/php5 - segfault when Aborted" Details: I am seeing this on fresh installs of Ubuntu 10.04 using the binary installer downloaded from EnterpriseDB: sudo ./postgresql-9.0.2-1-linux.bin --mode unattended --superpassword mypassword Launching psql fails: [email protected]:~$ /opt/PostgreSQL/9.0/bin/psql -Upostgres Aborted" On Wed, Dec 29, 2010 at 7:09 PM, Gabe Nell <[hidden email]> wrote: > > Launching psql fails: > > [email protected]:~$ /opt/PostgreSQL/9.0/bin/psql -Upostgres > Password for user postgres: > psql

Once connected provide login details. 3. Please don't fill out this field. This message contains information from EnterpriseDB Corporation that may be privileged, confidential, or exempt from disclosure under applicable law. this is done before /.profile can set TERM= in single-user mode so el_init() is called without TERM env var >How-To-Repeat: create /etc/termcap.small.db taken from /usr/src/etc/termcap.small it should have cons25 (or xterm

However there is different cases, for instance if you have a ZFS filesystem, or following CURRENT branch, or upgrading a 8.x or 9.x version. o kern/145621 net [bge] [panic] bge watchdog timeout --resetting -> cras o kern/145613 [boot] booting from zfs root not working p kern/145600 rpaulo TCP/ECN behaves different to CE/CWR than ns2 reference Aborted" From: moa To: pgsql-bugs(at)postgresql(dot)org Subject: Re: BUG #5807: psql fails to launch with "Cannot read termcap database; using dumb terminal settings. Do you know the exact Ubuntu package that I need to > > > install? > > > Apparently my colleague downloaded and installed a tarball of GNU > > termcap

Continuing the investigation... > > > -- > > Dave Page > > Blog:http://pgsnake.blogspot.com> > Twitter: @pgsnake > > > EnterpriseDB UK:http://www.enterprisedb.com> > The Enterprise PostgreSQL Company > > > -- Gabe [1] http://ubuntuforums.org/showthread.php?t=1329390-- Sent via pgsql-bugs mailing list ([hidden email]) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-bugs Dave Page-7 Reply | Threaded Open this post in threaded view ♦ ♦ | Problems with TermCap Richard Brumpton richard at internetsol.co.uk Sun Mar 16 15:27:38 GMT 2003 Previous message: Problems with TermCap Next message: March 25th -- Manchester BSD UG Messages sorted by: I have just rebuilt my machine to > > FreeBSD 5-Release > > > > Everything was working okay and I could connect via SSH to the machine... > > >

Cannot read termcap database; using dumb terminal settings. check over here o ports/146877 [repocopy] irc/kvirc-devel irc/kvirc4 o ports/146876 mnag [PATCH] databases/sqlite3: recover missing dependency o ports/146875 miwi [NEW PORT] www/thundersnarf: Web reporting and trendin o ports/146874 miwi [MAINTAINER] www/ap20-thundercache: port fix f add the "dumb" entry to etc/termcap.small to silence el_init() 2. Apparently my colleague downloaded and installed a tarball of GNU termcap 1.3.1.

back to summary 6. Everything works prefectly, except for not being able to run psql.... Free forum by Nabble Edit this page Network Filter Blog about network and security Saturday, 19 July 2014 UPGRADING FREEBSD 10 FROM SOURCES INTRODUCTION : ___________________________________________________________ There is many ressources online his comment is here On Fri, Jan 7, 2011 at 2:24 AM, Gabe Nell <[hidden email]> wrote: >> There was a change in 9.0.2 to use libedit instead of readline for >> this (readline is

Once you read all of the related pages of the Handbook and put the pieces together, you start to get the picture. Discussion Comment has been marked as spam. add the "dumb" entry to etc/termcap.small to silence el_init() 2.

Indeed, /etc/termcap file is a link to /usr/share/misc/termcap, and as /usr is not mounted, termcap file cannot be read.

Everything works prefectly, except for not being able to run psql.... In the end, I simply wish to sum up the upgrade from sources process with my words, and provide few simple scripts to help in the process. Try running "cap_mkdb termcap" > in /usr/share/misc, or possibly /etc. > > Just a wild guess. > > The other alternative might be permissions. > > Actually, if you have /usr/src Used last snapshot o bin/146821 [patch] info(1): respect LOCALBASE for INFODIR o ports/146820 hrs [UPDATE] multimedia/rtmpdump: update to 2.2d f ports/146818 [update] games/openarena latest release o ports/146816 portmgr [patch] Mk/bsd.port.mk: loosen

Thanks Dharmendra, however in Ubuntu there is no package called libtermcap, though it has been suggested that the libncurses5-dev package provides this [1]. However I tried this and I still get the same error. Powered by Blogger. http://outwardsound.com/freebsd-cannot/freebsd-cannot-open-termcap.html even though /etc/termcap.small.db is readable and cons25/xterm entry exists >Fix: looking in NetBSD, /bin/sh calls setenv/unsetenv for "TERM" before el_init() and calls el_set(el, EL_TERMINAL, term) when TERM changes.

Do you know the exact Ubuntu package that I need to > > install? > > Apparently my colleague downloaded and installed a tarball of GNU > termcap 1.3.1. > > I understand that I can withdraw my consent at any time. These scripts are merely an example. Aborted" Hi, It worked for me: "infocmp -C > /etc/termcap" Thank you so much! - Hari ‹ Previous Thread Next Thread › « Return to PostgreSQL - bugs | 1 view|%1

Do you know the exact Ubuntu package that I need to install? back to summary 5. o conf/145727 [pf.conf] pf rules not applied on boot if using inet6 f ports/145726 Update: x11/xlockmore to 5.30 o ports/145724 marcus net/netatalk and graphics/uniconv: add CONFLICTS o ports/145723 mm [patch] ftp/proftpd You have to get the sources of your version and your branch, for instance FreeBSD 10-STABLE.

We have > tested it at our end. Do you know the exact Ubuntu package that I need to > > > install? > > > Apparently my colleague downloaded and installed a tarball of GNU > > termcap We have >> tested it at our end. > > Thanks Dharmendra, however in Ubuntu there is no package called > libtermcap, though it has been suggested that the libncurses5-dev > See if it still happens for you on iterm2 http://code.google.com/p/iterm2/ I can't reproduce this.

You seem to have CSS turned off. sh doesn't call setenv() for "TERM" so getenv("TERM") will return NULL in single-user mode when used as the first shell. using dumb terminal settingsДобавлено: Чт 09 мар, 2006 2:03 pm Зарегистрирован: Пт 09 дек, 2005 10:48 amСообщения: 26Откуда: Питер После перезагрузки сервера глюка с правами. Захожу по терминалке и вижу : Aborted" In reply to this post by Dave Page-7 Just checking back to see if there have been any updates on this.Thanks!Gabe Apparently my colleague downloaded and installed a tarball of

I think I may need to resort to compiling from source otherwise?? -- Sent via pgsql-bugs mailing list ([hidden email]) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-bugs Gabe Nell Reply | Skip site navigation (1) Skip section navigation (2) Search Peripheral Links Donate Contact Home About Download Documentation Community Developers Support Your account Community Contributors Mailing Lists Subscribe User lists pgsql-admin pgsql-advocacy I do a fresh install of the latest debian. If there is not enough information on this article, I advised you to read the FreeBSD Handbook and to ask questions at the FreeBSD forum.

We have > >> tested it at our end. > > > Thanks Dharmendra, however in Ubuntu there is no package called > > libtermcap, though it has been suggested that View my complete profile OSCE certified OSCP certified Simple template. Aborted" On Jan 7, 6:35 pm, Sergey White <[hidden email]> wrote: > On Jan 7, 1:32 pm, [hidden email] (Dave Page) wrote: > > > > > On Fri, Jan 7, 2011 at